Tuto Shape3d Xflr5

Une fois le foil dessiné dans Shape3d, cliquez sur le menu Component -> Slices -> NACA profile
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Cette fonction permet d’ajuster un slice sur un profile NACA (ou un autre profile importé depuis un
fichier .dat), mais aussi d’exporter le foil pour qu’il soit facile a analyser dans Xflr5.

4-digit NACA Generator n
Chord (): 24.99 | Export... || Import...
Thickness | 13 % of c (3.25) IExport cross sections in

Camber (m): | 6 % of ¢ (1.50) Max at (p): | 40 % of ¢
Tilt (t): | - % of ¢ (1.00)

NACAG6413
OK Cancel

Note que le foil doit étre dessiné tel que sur la copie d’écran ci-dessus : avec le bord d’attaque vers la
droite, et le bord de fuite vers la gauche.

Xflr5 est un logiciel open source qui peut étre téléchargé sur le site http://www.xflr5.tech/xflr5.htm

L’export se compose de 20 profiles .dat et d’un fichier xml.

Ouvrez Xflr5 et cliquez sur le menu File -> New Project :



B xflr5 v6.53
File - Module

Options

-~

Open
Load Last Project
Insert Project

a Close the Project

[0

Save

Save Project As

1 C:/Users/thoma/Downloads/Foil Jet 1650_xflr5/Jet 1650.xfl

2 C:/Users/thoma/Downloads/Go Foil Decath_xflr5/Go Foil xfl
3 C:/Users/thoma/Downloads/test5.xfl

4 C:/Users/thoma/Downloads/Go Foil Decath_xflr5/Go Foil 2.xfl

5 C:/Users/thoma/Downloads/... /Go Foil HAXxfl
6 C:/Users/thoma/Downloads/Go Foil Thin.xfl
7 C:/Users/thoma/Downloads/foil decathlon.xfl

Exit

Puis File -> Open, et sélectionnez tous les .dat :

5 Open File

1 > CePC > Téléchargements > Foil Jet 1650_xflr5

Organiser v
& Téléchargemer # A
Documents

| Shape3dX »*
| Shape3dWeb
| Sh3dX »
. Cvepp *
c »
. Kerallan »*
Close up ART

_ InstallX

. Production

. SamplesX

@ OneDrive - Person:

[ CePC
I Bureau
Documents
[&=] Images
D Musique
B Objets 3D
& Téléchargements
Close up ART
. Disk motor
| flow5_v7.19_wir
Foil Jet 1650 xfli

Nouveau dossier

Nom

) Foil Jet 1650_profile_0_x44.25.dat

Modifié le

14/12/2021 10:07

| Foil Jet 1650_profile_1_x41.79.dat
| Foil Jet 1650_profile_2 x39.34.dat
| Foil Jet 1650_profile_3_x36.88.dat
| Foil Jet 1650_profile_4_x34.43.dat
| Foil Jet 1650_profile_5_x31.97.dat
| Foil Jet 1650_profile_6_x29.51.dat
| Foil Jet 1650_profile_7_x27.06.dat
| Foil Jet 1650_profile_8 x24.60.dat
| Foil Jet 1650_profile_9_x22.15.dat
| Foil Jet 1650_profile_10_x19.69.dat
| Foil Jet 1650_profile_11_x17.24.dat
| Foil Jet 1650_profile_12_x14.78.dat
| Foil Jet 1650_profile_13 x12.32.dat
| Foil Jet 1650_profile_14 x9.87.dat
| Foil Jet 1650_profile_15_x7.41.dat
| Foil Jet 1650_profile_16_x4.96.dat
| Foil Jet 1650_profile_17_x2.50.dat
| Foil Jet 1650_profile_18 x1.27.dat
| Foil Jet 1650_profile_19_x0.044.dat

14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07
14/12/2021 10:07

Ctrl+O

Ctrl+Shift+O

Ctrl+Shift+|

Ctrl+F4

Ctrl+S

Ctrl+Shift+S

Ctrl+7

v 0

Type Taille
Fichier DAT 3Ko
Fichier DAT 3 Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3Ko
Fichier DAT 3 Ko
Fichier DAT 3Ko
Fichier DAT 3Ko

X

£ Rechercher dans : Foil Jet 16...

= -

o @

Nom du fichier : | "Foil Jet 1650_profile_0_x44.25.dat" "Foil Jet 1650_profile_1_x41.79.dat" "Foil Jet 1650_profile_2_x39.34.dz | | XFLRS file (".dat *plr *wpa "l |

Ouvrir

I[ Annuler I-:E



Ensuite allez dans le menu Module -> Wing and Plane Design :

B xfIr5v6.53

File = Module View Foil Design Analysis Polars

B Close all Ctrl+0
Objec Direct Foil Design Ctrl+1 8 2
XFoil Inverse Design Ctrl+3
1 XFoil Direct Analysis Ctrl+5 b

Wing and Plane Design ~ Ctrl+6

Execute script Ctrl+X

Foil Jet 1650 profile 12 x1
Foil Jet 1650 Droflle 13 x1

FAl 1Ak 40N mvaflla 44 0

Puis Plane -> Import plane(s) from xml file(s) :

B xfir5 v6.53

Shift+F3

File Module View Plane Polars OpPoint Analysis
Q @ :l_ Define a New Plane F3
= Define (Advanced users)
Object explorer
Manage objects F7
11121 3] [= Current Plane

Import plane(s) from xml file(s)

|

Et sélectionnez le fichier xml exporté par Shape3d :

& Open XML File

» > CePC > Téléchargements > Foil Jet 1650 xflr5

Organiser ¥ Nouveau dossier
& Téléchargemer # A Nom -
5] Documents  # ) Foil Jet 1650_profile xfirxml
Shape3dX *
Shape3dWeb
Sh3dX »
Cvepp >V

I

Modifié le

14/12/2021 10:07

Graphs

Nom du fichier : | Foil Jet 1650_profile_xflrxml

0
X
v o O Rechercher dans : Foil Jet 16...
Ey @M @
Type Taille
Fichier XML 14 Ko
v || Plane XML file(*xmi) v

Dans le mode 3D View on peut vérifier que le foil a été importé correctement :
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Foil Jet 1650 profile —

164 me S
Plane Mass 1,000 kg ct Ratio = 4.746

Chora = 25014 cm v| Roor-Tip sweep =  26.743°

On peut alors directement lancer une analyse de portance depuis le menu Analysis -> Define an
Analysis :

B xfIr5v6.53
File Module View Plane Polars OpPoint Analysis Graphs Options ?

: — D I N — Defi Analysi F6
B&B D IC v o< > It
P TS Define an Analysis (advanced users) Ctrl+F6
rer
- - Define a Stability Analysis Shift+F6
ﬂ 2 3 ,=, ,%, | Import analysis from xml file
: View Log File L
Foil Jet 1650 profile ra gd o
ance ings

|

On peut faire une analyse a vitesse donnée (Type 1), ou a portance donnée (Type 2). L’analyse de
Type 2 est trés intéressante pour voir comment se comportera un foil avec un utilisateur donné :



E Analysis Definition - xflr5 v6.53

[ Auto Analysis Name  T24LT

Polar Type Analysis Inertia

(O Type 1 (Fixed Speed)
(® Type 2 (Fixed Lift)
(O Type 4 (Fixed aoa)
(O Type 5 (Betarange)

Ref. dimensions Aero data Extra drag

Vo= 36 km
o= 0.00 °©
o= 0.00 | ©

Wing Loading = 6.100 kg/m?2
Tip Re.sqrt(Cl) = 12000
Root Re.sqrt(Cl) = 164000
Vinf.sqrt(Cl) = 9.88 km/h

o] [ o

Il faut alors choisir la méthode dans I'onglet Analysis. Ring vortex fonctionne bien. On ne va pas
cocher Viscous pour 'instant, ce qui nous permettra d’obtenir la portance plus rapidement.




& Analysis Definition - xfIr5 v6.53

[ Auto Analysis Name  T2-vLM2-Inviscid

Polar Type  Analysis  Inertia  Ref. dimensions  Aerodata  Extradrag

Analysis Methods
O LLT (Wing only)
O Horseshoe vortex (VLM1) (No sideslip)

(® Ring vortex (VLM2)
O 3D Panels

Options

[ viscous

[] Tilted geometry - NOT RECOMMENDED
Ignore Body Panels - RECOMMENDED

Dans I'onglet Inertia on saisi le poids du rider + matos, 80kg par exemple :

Discard




& Analysis Definition - xfIr5 v6.53 ? X

[ Auto Analysis Name  T2-vLM2-1.0kg-x10.0cm-Inviscid

Polar Type Analysis Inertia Ref. dimensions Aero data Extra drag
Inertia properties
[] use plane inertia
Pne s o
K cos - an
Z_CoG = am

[save ]| oscard

Puis dans l'onglet Aero data if faut entrer la densité de I’eau 1000kg/m3 et sa viscosité 1.3%-6 m?/s :




% Analysis Definition - xfIr5 v6.53 ? X

Auto Analysis Name

Polar Type Analysis Inertia Ref., dimensions Aero data Extra drag

Air Data Ground Effect
Unit @ International (O Imperial [] Ground Effect
p=|  1000.0] kg/m3 Height = 0.C om

m3fs

From Altitude and Temperature

On clique sur le bouton Save, puis dans le mode Polar View on click sur le bouton Analyze pour lancer
I'analyse :

5 xfirs 653
File Module View Plane Polars OpPoint Analysic Graphs Ogtions 7

BEB bk =k
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> Foil Jet 1650 profile ~
-V M2-80.0ka-x10.( strt= [sam0] »

~ T2-VIM2-80.0ka-x10.( x
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it 1 store OpPoint

analyze
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Cette analyse calcule pour chaque inclinaison du foil (ici entre -5° et 20°) la vitesse qu’il faut pour que
le foil porte 80 kg (une portance de 784 N donc). On peut aussi afficher la trainé Fx pour chaque
vitesse (avec I'inclinaison qui lui correspond).




Ici on voit que pour ce foil de 1650cm? low aspect (copie grossiére du Naish Jet 1650), a 5 m/s (~10
kt) il faut une inclinaison de 2°. En dessous de 6 kt il faut plus de 12°... On peut en déduire qu’on peut
commencer a pomper vers 6 kt, mais que la navigation normale ne se fait qu’a partir de 10 kt en
gros.

La trainée Fx est ici uniquement la trainée résiduelle due aux tourbillons, et on voit qu’elle est
d’autant plus grande que la vitesse est faible et I'inclinaison grande. Elle ne fait que baisser quand la
vitesse augmente, ce qui n’est pas réaliste car il n’y a pas la trainée visqueuse.

Pour ajouter la trainée visqueuse c’est un peu plus long. Il faut aller dans le menu Module -> XFoil
Direct Analysis :

‘ xflr5 v6.53
File = Module View Plane Polars OpPoint Analysis Graphs Options ?

lg Close all Ctrl+0
Objec Direct Foil Design Ctrl+1 & X
XFoil Inverse Design Ctrl+3
1 XFoil Direct Analysis Ctrl+5 x

Wing and Plane Design Ctrl+6 ’[ .

Execute script Ctrl+X

-~ AnAn

Puis dans le menu Analysis -> Batch Analysis :

B xfir5 v6.53
File Module View Foil Design Analysis Polars Operating Points Graphs

@ L < P Define an Analysis F6

= Batch Analysis Ctrl+F6
Object explorer

Import Analysis from xml file

(7))
Lad

112

=| [& '
{— XFoil Advanced Settings

Foil Jet 1650 profile 0 x¢ View Log File
Foil 1et 1650 nrofile 10 x r————

Sélectionner alors tous les profiles, et lancer les analyses de Type 1 entre -5° et 20° :




& Multi-threaded batch analysis - xflr5 v6.53

Foil Jet 1650_profile_0_x44.25

Foil Jet 1650_profile_10_x19.69 dy7.75 dihedral-3.572
Foil Jet 1650_profile_11_x17.24 dy9.13 dihedral-4.512
Foil Jet 1650_profile_12_x14.78 dy10.66 dihedral-5.648
Foil Jet 1650_profile_13_x12.32 dy12.35 dihedral-7.041
Foil Jet 1650_profile_14_x9.87 dy14.26 dihedral-8.952
Foil Jet 1650_profile_15_x7.41 dy16.42 dihedral-11.937
Foil Jet 1650_profile_16_x4.96 dy18.92 dihedral-15.461
Foil Jet 1650_profile_17.x2.50 dy22.03 dihedral-20.003
- 18.x1.27 dy24.12 dihedral-24.763
ile_19_x0.044 dy28.05 dihedral-29.622
Foil Jet 1650_profile_1_x41.79 dy0.15 dihedral0.138
Foil Jet 1650_profile_2_x39.34 dy0.49 dihedral0.035
Foil Jet 1650_profile_3 x36.88 dy0.98 dihedral-0.142
Foil Jet 1650_profile_4 x34.43 dy1.61 dihedral-0.389
Foil Jet 1650_profile_5_x31.97 dy2.40 dihedral-0.705
Foil Jet 1650_profile_6_x29.51 dy3.30 dihedral-1.095
Foil Jet 1650_profile_7_x27.06 dy4.27 dihedral-1.564
Foil Jet 1650_profile_8 x24.60 dy5.33 dihedral-2.123
Foil Jet 1650_profile_9_x22.15 dy6.49 dihedral-2.785

Re Mach NCrit Actions A
1 0% 750 0 9
2 % 0 ] .
3 x 0 ] .
4 % 0 9 %
s X 0 9 s
& X 0 9 .
b x 0 9 .
g X 0 9
s X 0 9
10 X 0 9 .
aa - - A
Polar type
@T1 Oomn OT3
Forced Transitions
Top transition location (x/c) | 1
Bottom transition location (x/c) 1
Analysis Range
specify: @ a O d [ From zero
Min Max Increment
Alpha -5.000 20.000 ‘ 0.500

Advanced Settings| | Clear Output

Initialize BLs between polars
Store operating points
[ Update polar view

Max. Threads to use for the analysis:

"B

Ca prend plusieurs minutes, et a la fin s’affichent les polaires pour tous les angles et des nombres de

Reynolds entre 4000 et 3¢6.

B xfus v653
Fle Module View Fol Deign Amsbsis Polrs OpentingPoints Guphs Ogtions ?
BEB Mk

Object explorer

Foil Jet 1650 proffle
Foil Jet 1650 profile

Foil Jet 1650 profile 8 x24
Foil Jet 1650 profile 9 x22

Foil Jet 1650 pro
Thickness
™

10.0

15.0

10.0

15.0

20.0

Directfoilanalysis 8 X
Anslyss settngs
®o Oa

Sequence
Strt= [ o0m] «
End= [ a0.000] *

0.500] *

fscous [ InteL
Store Opp.

Anaivze

On peut alors retourner dans le menu Module -> Wind and Plane Design, et définir une nouvelle

analyse, en cochant la case Viscous cette fois-ci :




% Analysis Definition - xfIr5 v6.53 ? X

Auto Analysis Name

Polar Type Analysis Inertia Ref., dimensions Aero data Extra drag
Analysis Methods
O LLT (Wing only)
(O Horseshoe vortex (VLM1) (No sideslip)
(® Ring vortex (VLM2)
(O 3D Panels

Options

Viscous
[] Tilted geometry - NOT RECOMMENDED

On obtient une portance identique a la précédente analyse, mais une trainée supérieure qui

augmente a grande vitesse. |l y a donc une trainée minimum pour une inclinaison et une vitesse
donnée :

Alpha

~ Foil Jet 1650 profile
T2-VLM2-80.0ka-x10.0ct
T2-VLM2-80.0ka-x10.0ct

it I store opPoint

analyze

Il y a donc une plage d’utilisation optimale entre 9 kt et 12 kt.



Notez qu’on peut changer I'unité de vitesse dans le menu Options -> Preferences, mais qu’il y a un
petit bug qui fait que I'affichage revient toujours a m/s avec une échelle qui n’est pas toujours

bonne. Il faut alors faire click droit -> Current Graph -> Define Grapgh Settings, puis Reset Graph
Scales.

On peut comparer ces résultats avec un foil de 1040 cm? de plus haut aspect ration (copie grossiére

du Naish Jet HA 1040) :
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18 E S a s0Apha Analysis settngs
2|3 t § 4 sequence
~ Foil Jet HA 1040 profile 3 °
TR ¢ 1
B - -x10.0a x :
T2-VLM2-80.0ka-x10.0a = L‘r End= 20,000
3 o[ osml>
3 Emitur B store OpPont
2 Anaiyze
2
3
3
!

50000

JetHA T040"

On voit ici que I'inclinaison a 10 kt n’est pas de 2° mais 4°. On descend a 2° vers 12 kt. Le minimum de

trainée est autour de 14 kt, et la plage d’utilisation optimale entre 12 kt et 16 kt.



Ces résultats ne sont pas 100% fiables, mais assez fideles a la réalité. Nous avons fait une
comparaison quantitative avec les résultats obtenus avec OpenFoam (un gros logiciel de simulation,
les analyses sont tres longues et demandent des gros ordis) par Décathlon et on était trés proche
niveau portance pour des inclinaisons allant jusqu’a 15°. L’avantage ici est que ¢a prends moins de 5
min tout compris pour obtenir une analyse.

Vous pouvez aussi faire des analyses de Type 1 pour obtenir I'inclinaison optimale a vitesse donnée
(10-15-20 kt ici) :

~ Foil Jet HA 1040 profile
-10.0 kt-Panel-80.0ka
T1-15.0 kt-Panel-80.0ka
T1-20.0 kt-Panel-80.0ka-
T2-Panel-80.0ka-x10.0cr
T2-VLM2-80.0ka-x10.0at
T2-VLM2-80.0ka-x10.0ct

Emtur & store OpPoint

analyze

£

1500 ﬂ-
C
/

JetHA T040"

Il est aussi possible de charger le stab pour avoir portance et trainée de I'ensemble.

Le logiciel Flow5 est une version avancée de Xflr5, payante, qui permet de faire la méme chose, avec
en plus la prise en compte de l'interaction foil/stab

(https://flow5.tech/docs/flow5 _doc/Analysis/VPW.html), et la possibilité de faire de I'optimisation
(https://flow5.tech/docs/flow5 doc/MOPSO/MOPSO.html).




